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Introducing Media Player

Media Player is a Microsoft application for Windows that controls multimedia-hardware
devices and plays media sequences, such as video clips, animation, and waveform and
Musical Instrument Digital Interface (MIDI) sound files. Media Player can interact with any
device accessible through the Media Control Interface (MCI), such as videodisc players and
audio CD players, or any device for which the manufacturer has provided an MCI-
compatible driver. Media Player supports object linking and embedding (OLE) and acts as
an OLE server for the media clips it controls.

Media Player can also be embedded in a document belonging to another application, such
as a spreadsheet or a word-processing document. When inserted in another application, the
embedded version of Media Player, its media sequence, and a selection of the media
sequence (if it exists), is called a media-clip object.

The main window in Media Player lets you control the sequence you are playing, and shows
you the elapsed playing time from the beginning of the sequence.




See Also
Playing a Media Sequence

Embedding a Media Sequence in Another Application




Starting Media Player

You can start Media Player in any of the following ways:

. From Program Manager, choose the Media Player icon from the Video for Windows
group.

. From Program Manager, choose the Run command and then type the Media Player
command line.

. Drag a file icon from File Manager and drop it on the Media Player icon or in the
Media Player window.

. From within an OLE client application, choose a Media Player object.

If you start Media Player from Program Manager, you can specify the particular device and
file you want to use.



See Also
Playing a Media Sequence

Embedding a Media Sequence in Another Application
Specifying a Media Device
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Specifying a Media Device

Media Player supports two types of devices: simple and compound. A simple device is
ready to play when you choose it. Compound devices, on the other hand, also require you

to specify the media file you want to open.

You choose devices from the Device menu. However, for Media Player to list a device on the
Device menu, the device and its software driver must be installed correctly and configured

for your system.

E To specify a simple device
. From the Device menu, choose the media device you want.

Simple devices do not have an ellipsis.

@ To specify a compound device
1 From the Device menu, choose the media device you want.

Compound devices have an ellipsis (. . .).
2 Type or select the name of the file you want to play.

3 Choose OK.
You can now open files available for that device.

@ To specify a different device
. From the Device menu, choose the device you want.

Or, choose a different file type from the Open dialog box.




See Also
Playing a Media Sequence
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Opening a File

Media Player associates the various types of media files with the appropriate devices and
automatically allocates the needed playback resources when you open a file.
» To open a file
1 From the File menu, choose Open.
2 Type or select the name of the file you want to open.
To change the device type, select another entry in the List Files Of Type box.

3 Choose OK.



See Also
Playing a Media Sequence
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Closing a Media Device

You can close simple and compound media devices by using the Close command; however,
the effects of closing each device differ slightly.

For simple devices, Media Player releases control of the device, allowing other applications
to access the device. If a media sequence is playing when a simple device is closed, the
sequence continues to play.

For compound devices, Media Player closes the file, then releases control of the device. If a
media sequence is playing when a compound device is closed, the sequence stops playing.
» To close a media device
. From the File menu, choose Close.



See Also
Playing a Media Sequence
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Quitting Media Player

When you close Media Player, simple devices, such as audio CD players, continue to play.
Compound devices stop playing when you quit the application.

» To quit Media Player

. From the File menu, choose Exit.

» To quit Media Player from a media-clip object

. Select another item or area within the application.



See Also
Starting Media Player
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Playing a Media Sequence

= To play or restart a paused media sequence
. Choose the

Play button.

» To play an embedded media clip

- Double-click the media-clip icon.
» To play a marked selection in a media sequence
. Press ALT while choosing the Play button.

Or, choose Play if the sequence is embedded in a document.
= To pause play
. Choose the
» Pause button.



See Also

Changing the Scale
Media Player Buttons
Opening a File
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Stopping a Media Sequence or Device

» To stop play

Choose the

E Stop button.

T

H.0 H

To stop playing an embedded media clip
Press ALT+F4, click the right mouse button, or double-click the Control menu.

: To stop playing an embedded media clip running in full-screen mode

A

Press the ESC key, or press the left mouse button.

A

To eject a compact disc or other media element

A

Choose the

E Eject button.

The Eject button is available only with devices that include a software-based eject
function.



See Also
Media Player Buttons

Setting Video Characteristics
Quitting Media Player
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Moving to Another Position

You can move within a media sequence to play your favorite song or view a particular video
sequence.

To change the playback position

S

Drag the slider to the desired position on the track bar.

-Or-

9

Use the scroll arrows at the right edge of the track bar.

-Or-

A

Use the LEFT ARROW, RIGHT ARROW, PAGE UP, PAGE DOWN, HOME, and END keys.

-Or-

S

Choose the
E Page Right,
Page Left,
Next Mark, and
E Previous Mark buttons.




See Also
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Selecting Part of a Media Sequence

You can mark the beginning and end of a selection, and then play only that selection.

: To mark a selection using Media Player controls
1 Drag the slider to the beginning of the section you want to mark.

2 Choose the <] Mark In button.
3 Drag the slider to the end of the section you want to mark.

4 Choose the Mark Out button.
Or, mark the beginning of the selection, then hold down the SHIFT key as you drag the

slider to the end of the selection you want to mark.

i To mark a selection using the Selection command
1 From the Edit menu, choose Selection.

Or, double-click the scale rule.
2 Select From and type the selection's beginning time, frame, or track.
3 Set the section range using either the To box or the Size box.

: Select the To box and type the selection's ending time, frame, or track.

: Select the Size box and type the selection's duration as elapsed time, frames, or

tracks.
4 Choose OK.
Note After you've marked a media sequence, don't change the current track-bar scale.
Changing the scale clears the selection.




See Also
Embedding a Media Sequence in Another Application

Set Selection Dialog Box
Media Player Track Bar
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Changing the Scale

Media Player displays one of three scales beneath the track bar.

S

Time scale, which shows time intervals

Frames scale, which shows frames of a video sequence

Track scale, which shows tracks

You can use a time scale for any media sequence. However, some media types, such as CD
Audio or Video for Windows, can use other scales to locate specific portions of a media
sequence.

Q

A

To change scales

From the Scale menu, select Time, Frames, or Tracks.

Changing the scale erases any mark set in the current media sequence.



See Also
Selecting Part of a Media Sequence



A

Setting Media Player Options

Media Player provides several playback and display options for embedded media clips. Two

of these options (Auto Rewind and Auto Repeat) can also be used when Media Player runs
as a stand-alone application.

: To set Media Player options

1 From the Edit Menu, choose Options.

2 Select the display and playback options you want.
3 Choose OK.



See Also
Options Dialog Box
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Setting Video Characteristics

The Video for Windows device (an MCI device), which Media Player uses to play video
sequences, has its own configuration options. You can set its configuration options using
the Configure command from the Control Panel Drivers application.

: To set video characteristics using the Configure command

1 From the Device Menu, choose Configure.

If the Configure command is unavailable or the Video Playback Options dialog box does
not appear, you must first select the Video for Windows device type and specify an .AVI
file containing a video sequence.

2 Select the options you want.
3 Choose OK.

You can also set configuration options using the Control Panel Drivers application.

i To set video characteristics using Control Panel

1 Start Control Panel.

2 Choose the Drivers application.

3 Select the Microsoft MCI AVI Driver.
4 Choose the Setup button.

5 Select the options you want.

6 Choose OK.

The changes you make for a specific video sequence apply only to that sequence.

To set specific options for all video sequences

Choose the Set Default button.

To set the Video Playback options for an embedded media clip

©1C|1S1C

Choose the Set Default button.




See Also
Video Playback Options Dialog Box
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Controlling Media Player's Appearance

For devices that do not require a playback window, Media Player provides an abbreviated
form of its controls, which includes the track bar and the Play/Pause and Stop buttons. If
the device (video and animation, for example) requires a playback window, it appears
above the abbreviated controls.

To toggle between Media Player's normal and abbreviated display modes

S

Press CTRL+W.

Or, double-click the Media Player title bar.

To double the size of the abbreviated mode's display window

Choose the Maximize button.

To resize the abbreviated mode's display window

Drag the window frame.

To restore the window to the default size

2e81C)81S

Choose the Restore button.




See Also
Media Player Keys
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Embedding a Media Sequence in Another Application

Using OLE technology, you can embed media-clip objects in other applications, a sound clip
in a spreadsheet, for example, so that they will play when users choose the objects' icons.

: To embed a media clip in an application
1 Start Media Player.

2 From the File menu, choose Open and select the file or device you want to embed.

3 If the embedded media clip is a video clip or animation, move the slider to a frame that
best represents the entire clip.

The selected frame is used as the icon for the media-clip object.
4 From the Media Player Edit menu, choose Copy Object.
5 Select the application or document where you want to insert the media clip.
6 From the application's Edit menu, choose Paste or Paste Special to embed the media clip.
Note If the Paste or Paste Special command doesn't properly insert the media clip into the

application, refer to your application's documentation for additional information about
using OLE objects from another application.



See Also
Setting Media Player Options
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Editing an Embedded Media Clip

You can edit embedded media clips from within the application. You simply start Media
Player from the application, edit the media clip, and then close Media Player.

: To edit an embedded media clip

1 Open the document that contains the embedded media clip.
2 Select the embedded clip you want to edit.
3 From the Edit menu, choose Media Clip Object, and then choose Edit.
4 Edit the media clip.
5 From the Media Player File menu, choose Update.
This updates the embedded media clip in the other application.
6 From the Media Player File menu, choose Exit.



See Also
Setting Media Player Options




Options Dialog Box

Option

Description

Auto Rewind

Auto Repeat

Caption

Border
Around
Object

Play In Client
Document

Control Bar
On Playback

Dither
Picture To
VGA Colors

See Also

Rewinds a media sequence, selection, or clip when Media Player
reaches the end.

You can use Auto Rewind if Media Player is open as a stand-alone
application, or from a media-clip object.

Plays a media sequence, selection, or clip as a continuous loop.

You can use Auto Repeat if Media Player is open as a stand-alone
application, or from a media-clip object.

Adds a caption below the media-clip object. The caption text
appears in the box to the right and can be edited.

Inserts a thin border around the window of the media-clip object.

Plays a media clip within the application window that contains
the object.

If this option is not selected and the Control Bar On Playback
option is selected, the media-clip object opens another window
containing the abbreviated controls (and playback window, if
necessary) to play the embedded media clip.

Displays a playback control bar when the media-clip object is
selected. The control bar includes a Play/Pause button, a Stop
button, and a track bar.

Dithers the image of the place marker using the standard VGA
color palette. With an embedded video clip or animation, the
media-clip object is marked in an application with a frame from
the embedded media clip instead of an icon.

If not selected, the place marker uses the color palette of the
video clip or animation, creating possible color distortion.

Setting Media Player Options




Video Playback Options Dialog Box

For the Video for Windows device, the configuration options let you adjust viewing
characteristics of a video sequence.

Option Description

Zoom By 2 Doubles the frame size of the playback area in normal and
full-screen video modes.

Play Only If Waits to play the video sequence until the audio resources

Waveform become available (given that the video sequence includes a

Device sound track and the audio resources are already in use).

Available If not selected, Media Player plays the video sequence
immediately with or without the soundtrack, depending on
the availability of the audio resources.

Seek To Plays the nearest full frame when a jump to a non-consecutive

Nearest Full frame occurs (always displaying the correct frame image).

Frame If not selected, Media Player chooses the exact frame when a
jump to a non-consecutive frame occurs. Media Player
displays the current frame data correctly. However, if the
frame depends on other frames for some of its data, the
frame display might contain inaccuracies.

Skip video Prioritizes the sound track of a video sequence above the

Frames If frame. If Media Player cannot maintain the playback pace, it

Behind skips video frames to keep pace with the audio track.
If not selected, Media Player plays all frames of the video
sequence and pauses the audio track as needed.

Don't Buffer Provides a slightly faster playback rate by omitting updates to

Offscreen an off-screen buffer of the playback window. If your system
cannot keep pace with the playback rate of a video sequence,
but lags only slightly, this option might let you play the video
sequence at its normal rate without dropping frames.
If you select this option and your system still lags behind the
playback rate of the video sequence, the video images might
become fuzzy. Also, because a copy of the playback window is
not updated off screen, jumping to another position within a
video sequence will probably result in a distorted image until
Media Player reaches the next full frame.

See Also

Setting Video Characteristics




Set Selection Dialog Box

The Set Selection dialog box lets you mark a selection for playback.

Option Description

All Selects the entire media sequence.

None Erases an existing selection or selection markers.

From Creates a new selection or edits an existing selection. After selecting
From, you type or edit the values in the From, To, and Size boxes.

From Specifies a value for the selection's starting point.

box

To box Specifies a value for the selection's ending point.

Size box  Specifies the length of the selection. With a value from either the From
or the To box, the value in the Size box determines where the other
selection marker is placed.

Note Entries for the From, To, and Size boxes use the same units as those currently used
for the reference scale: time, frame number, or track and elapsed time within the track.



See Also
Selecting Part of a Media Sequence



simple device

A device that plays a media sequence without requiring you to specify an associated media
file. For example, an audio CD player is a simple device.



compound device

A device that plays media sequences by accessing data files on disk or CD-ROM. For
compound devices, you must specify both the device and the file you want to play.



Media Control Interface (MCI)

A standard control interface for multimedia devices and files. MCI allows a multimedia
application to control a variety of multimedia devices and files.



track bar

A bar that appears above the control buttons in Media Player and represents the duration of
the current media sequence. The left end represents the beginning of the sequence and the

right end represents the end of the sequence. The track bar also includes a slider that
indicates the current playing position.



slider

A pencil-shaped pointer on the Media Player track bar that shows the current playing
position. You can move the slider to different positions along the track bar.



Product Support

If you purchased Video for Windows directly from Microsoft or through a retail outlet,

product-support information is listed at the end of the Video for Windows User's Guide
(following the index).

If your copy of Video for Windows is part of an OEM product, you should consult the OEM
product documentation for addition support information.
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Media Player Buttons

Use the following buttons to perform Media Player functions:

Button

Description

>
L
A

E

CIREIRF

B E

See Also

Plays the content of the current media device.
Pauses the device that is currently playing.

Stops the media sequence or device that is currently playing.

Moves the slider to the closest mark to the left, or to the
beginning of the track bar if both marks are to the right of the
slider.

Pressing SHIFT+Previous Mark selects the portion of the video
sequence traversed by the slider.

Moves the slider to the closest mark to the right, or to the end of
the media sequence if both marks are to the left of the slider.
Pressing SHIFT+Next Mark selects the portion of the video
sequence traversed by the slider.

Steps backward through the current media sequence in
approximately 10 percent increments.

Steps forward through the current media sequence in
approximately 10 percent increments.

Ejects the media cartridge from the device.

This button is enabled for devices that have programmatic
control of their eject function.

Marks the beginning of a selection for playing or for embedding
in another application.

Marks the end of a selection for playing or for embedding in
another application.

Playing a Media Sequence
Stopping a Media Sequence or Device

Moving to Another Position

Selecting Part of a Media Seqguence




A

Media Player Track Bar

| q JEREY|
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Represents the open media sequence. The slider indicates the current playing position of
the media sequence. You can change the current playing position by dragging the slider to
another location along the track bar, or by choosing the scroll arrows on the right.



See Also

Moving to Another Position

Selecting Part of a Media Sequence
Changing the Scale

Controlling Media Player's Appearance
Options Dialog Box
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File Menu Commands

The File menu contains the following commands.
Item Does this

Open Opens a data file. Based on the filename extension, Media Player
chooses an appropriate device to play the file.

Close Releases the device allocated by Media Player and, for compound
devices, closes the open media file.

Exit Closes the device and file allocated by Media Player.

See Also
Closing a Media Device

Opening a File
Quitting Media Player

Playing a Media Sequence
Specifying a Media Device
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Edit Menu Commands

The Edit Menu contains the following commandes:

Item Description

Copy Copies Media Player and the current media file to the Clipboard as a

Object media-clip object so it can be inserted into another application.

Options Sets playback and display options for the current media sequence or
embedded media clip.

Selectio Selects a portion of the current media sequence for playback.

n

See Also

Embedding a Media Sequence in Another Application
Editing an Embedded Media Clip
Setting Media Player Options

Selecting Part of a Media Sequence
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Device Menu Commands

The Device Menu lists the devices installed on your system. The following table describes
some of the device types that Media Player recognizes. Other devices will appear on the
menu if they are properly installed.

Item Specifies a device that plays

Animation Animations saved in the Microsoft Multimedia Movie file format.

CD Audio Digital audio from a CD.

Video for Video sequences in the .AVI file format. The Video for Windows

Windows device supports video sequences made from 8-bit, 16-bit, and
24-bit color images, with or without an accompanying sound
track.
The Configure command for the Video for Windows device
controls the video mode and some video-playback options.

MIDI MIDI (.MID or .RMI) files. The number of voices and the degree

Sequencer of polyphony depend on the sequencer's characteristics.

Sound Digital audio (.WAV) files.
The Configure command for the Sound device controls the
amount of extended memory (RAM) used to buffer the sound
files.

Video VCR tapes.

Cassette

Player

Videodisk Videodisks.

See Also

Setting Video Characteristics
Specifying a Media Device
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Scale Menu Commands

The Scale Menu identifies the following scales to use with different types of media.

Item Changes the scale to
show

Time Scale Elapsed time

Frames Frame sequence
Scale

Track Scale Tracks

See Also

Changing the Scale
Selecting Part of a Media Sequence
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Media Player Keys

You can use the following key equivalents with Media Player.

Button-Selection Keys

To select Press

Next control button. TAB

Previous control button. SHIFT+TAB

Current control. SPACEBAR
Menu-Command Keys

To Press

Edit the playback device driver configuration. (Same as the CTRL+D

Configure command on the Device menu.)

Select a new file to play with Media Player. (Same as the Open CTRL+F

command on the File menu.)

Edit the current selection. (Same as the Selection command on CTRL+L

the Edit menu.)

Close the current file or device. Or, to update an embedded CTRL+U

object you have edited. (Same as the Close command on the

File menu.)

Toggle between normal and abbreviated display modes. CTRL+W
Playback Keys

To Press

Play the media content, or to pause playback. CTRL+P

Play a marked selection in the media content. ALT+P or

ALT+CTRL+P

Stop playing the current media sequence.

CTRL+S or ESC

Slider Keys
To move the slider to the Press
Beginning of the media content. HOME
End of the media content. END
Next page of the media content. PAGE DOWN
Previous page of the media content. PAGE UP
Beginning of the next track (Tracks scale only). CTRL+PageDow

n

Beginning of the previous track (Tracks scale only). CTRL+PageUp
Left (backward) in the media content. LEFT ARROW
Right (forward) in the media content. RIGHT ARROW



Zoom Keys

To Zoom the playback image size to Press

Normal size. CTRL+1
Twice the frame size. CTRL+2
Three times the frame size. CTRL+3
Four times the frame size. CTRL+4

See Also

Opening a File
Closing a Media Device
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